Email delivery delayed

Incident Report for Crewmojo

Resolved

This incident has been resolved.
Posted Jun 05, 2026 - 10:26 AEST

Monitoring

Due to an issue with a service provider, email delivery is currently delayed. It is in a recovering state; however, there is a backlog of emails at the provider, which is causing delays in emails arriving in users' inboxes.
Posted Jun 05, 2026 - 08:45 AEST
This incident affected: Crewmojo Platform.